読者です 読者をやめる 読者になる 読者になる

rakugakibox.net

技術ノート。兼JS/CSS実験場。 ♡:Java, Spring, AWS.

Eclipse (Pleiades) or Maven で Java8 対応の CheckStyle を使う

Java8 のシンタックス (ラムダとか!) を使ってるコードに CheckStyle したら、 Eclipse (Pleiades) でも Maven でもエラーになった。 どっちも CheckStyle 本体のバージョンが古いのが原因だった。 Java8 対応のバージョンになるのも時間の問題だろうけど、…

Eclipse に lombok 1.14.4 を導入したらコンテンツアシストが超絶遅くなった

Java で Getter/Setter 等の冗長コードがすっきり書ける lombok。 最新版(1.14.4) を Eclipse に導入したら、コンテンツアシストが超絶遅くなってしまった。